CVE-2024-23730: llama-hub · Unsafe Yaml Deserialization
Affects llama-hubSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.0.67 as a priority.
Data as of 27 Oct 2026, 18:27 UTC
- Patch
- Available – fixed in 0.0.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade llama-hub to 0.0.67.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIllama-hub | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
References
- nvd.nist.gov/vuln/detail/CVE-2024-23730 (opens in a new tab)
- github.com/run-llama/llama-hub/pull/841/commits/9dc9c21a5c6d0226d1d2101c3121d4f085743d52 (opens in a new tab)
- github.com/run-llama/llama-hub/commit/c01416e737c7747a213a79881b8308c41d043515 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/llama-hub/PYSEC-2026-393.yaml (opens in a new tab)
- github.com/run-llama/llama-hub (opens in a new tab)
- github.com/run-llama/llama-hub/blob/v0.0.67/CHANGELOG.md (opens in a new tab)
- github.com/run-llama/llama-hub/releases/tag/v0.0.67 (opens in a new tab)
- pypi.org/project/llama-hub (opens in a new tab)