vault-java-driver, a Java client for HashiCorp Vault, parses Vault's JSON responses with a vendored minimal-json
Affects vault-java-driverSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 7.0.0 : update vault-java-driver when convenient.
Data as of 5 Nov 2026, 10:31 UTC
Thin evidence
One scorer or none| CNA (Echo) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 7.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenio.github.jopenlibs/vault-java-driverpkg:maven/io.github.jopenlibs/vault-java-driverOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vault-java-driver to version 7.0.0 or later, where the issue is fixed. Additionally, using Vault version 1.20 or later mitigates the issue by rejecting deeply nested values beyond 298 levels. No other mitigation is indicated.
Description
The vault-java-driver, a Java client for HashiCorp Vault, uses a minimal-json parser without a nesting depth limit. This can cause a StackOverflowError when parsing deeply nested JSON values, which escapes standard exception handling and terminates the reading thread. An attacker with write-only Vault token permissions on a KV v2 path can store such deeply nested values, causing subsequent reads through the driver to fail. This vulnerability affects versions 5.2.0 through 6.2.3 and requires Vault 1.19.x or earlier, as later Vault versions reject deeply nested values. The issue is fixed in vault-java-driver version 7.0.0.