Skip to main content
CVE-2026-123521VulnerabilityPublished

Vikunja before 2.7.1 contains an improper restriction of excessive authentication attempts vulnerability that allows

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123521· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium : upgrade to 2.7.1 when convenient.

Data as of 8 Nov 2026, 06:49 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.0
CNA (VulnCheck)CVSS 3.15.9
Patch
Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade vikunja to 2.7.1.

Affected software

ProductAffectedFixed in
go-vikunjavikunjaAffected
  • <2.7.1
Fixed in
  • 2.7.1
Govikunjapkg:golang/vikunjaOther threatsAffected
  • <2.7.1
Fixed in
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Vikunja version 2.7.1 and later. Users and administrators should upgrade to version 2.7.1 or newer to remediate this vulnerability. Until patched, restricting access to authenticated sessions and monitoring for suspicious activity may help reduce risk, but the primary mitigation is upgrading the software.

Description

Vikunja versions prior to 2.7.1 have a vulnerability that allows attackers holding a valid session to brute-force account passwords through unthrottled re-authentication endpoints. Specifically, attackers can repeatedly attempt password guesses via the /user/settings/totp/disable endpoint without triggering lockout mechanisms, enabling them to disable two-factor authentication (TOTP) without a code. This flaw can lead to persistent account takeover.

References

Community reviews

Loading reviews…