Skip to main content
VulnerabilityPublished

CVE-2026-113726: virtualenv activate runs commands from the environment name in zsh with PROMPT_SUBST

Affects virtualenvSource GCVE Database

0
Compare
Authoritative record:CVE-2026-113726· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 21.14.4 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.8
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 21.14.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenv to 21.14.4.

Affected software

ProductAffectedFixed in
Bitnamivirtualenvpkg:bitnami/virtualenvOther threatsAffected
  • <21.14.4
Fixed in
  • 21.14.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade virtualenv to version 21.14.4 or later, where this issue is fixed. No other mitigation is required if upgrading is possible. Users of bash or zsh without PROMPT_SUBST enabled are not affected by this vulnerability.

Description

A command injection vulnerability exists in virtualenv versions prior to 21.14.4 when used with zsh shells that have PROMPT_SUBST enabled. The vulnerability arises because the environment name is assigned to the shell prompt (PS1) without proper escaping, allowing attacker-controlled input to execute commands each time the prompt is drawn. This affects virtualenv versions before 21.14.4 and is fixed in 21.14.4.

References

Community reviews

Loading reviews…