CVE-2026-113776: virtualenv activation scripts run code from a path that contains a placeholder name
Affects virtualenvSource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 21.14.2 soon.
Data as of 29 Oct 2026, 14:41 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.8 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 21.14.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade virtualenv to 21.14.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamivirtualenvpkg:bitnami/virtualenvOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade virtualenv to version 21.14.2 or later, where this issue is fixed. No other mitigation is required as the vulnerability is resolved in the official patch.
Description
A vulnerability in virtualenv versions from 20.26.6 up to but not including 21.14.2 allows code execution when activating a virtual environment. The issue arises because the activation scripts replace placeholders in the environment path or prompt in multiple passes, enabling crafted values containing placeholder names to break out of quoting and execute arbitrary code during activation. This affects activation via bash, fish, xonsh, or activate_this.py. The vulnerability is fixed in version 21.14.2.
References
- github.com/pypa/virtualenv/commit/602b26623a724827ff171bf11fef4ad186d01f74 (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.2 (opens in a new tab)
- github.com/pypa/virtualenv/security/advisories/GHSA-8rjx-v5ww-45pp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113776 (opens in a new tab)