Skip to main content
CVE-2026-115586VulnerabilityPublished

virtualenv: Bash activator leaves the --prompt value unescaped in PS1 when promptvars is off, so prompt expansion

Affects virtualenvSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115586· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 21.14.13 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.07.1
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 21.14.13
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenv to 21.14.13.

Affected software

ProductAffectedFixed in
Bitnamivirtualenvpkg:bitnami/virtualenvOther threatsAffected
  • >=21.14.9 <21.14.13
Fixed in
  • 21.14.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade virtualenv to version 21.14.13 or later, where this issue is fixed. Avoid using untrusted input for the --prompt option. Alternatively, ensure that promptvars is enabled or POSIX mode is set during activation to prevent unescaped prompt expansion.

Description

A vulnerability in virtualenv versions 21.14.9 through 21.14.12 allows an attacker-controlled --prompt value to be copied into the PS1 environment variable without proper escaping when promptvars and POSIX mode are disabled. This can lead to command execution when prompt expansion occurs. The issue is fixed in version 21.14.13.

References

Community reviews

Loading reviews…