Skip to main content
VulnerabilityPublished

CVE-2026-113723: virtualenv · Bash prompt values can change meaning under older compatibility modes

Affects virtualenvwrapperSource GCVE Database

0
Compare
Authoritative record:CVE-2026-113723· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 6.1.1_4 or 4.8.4_2 soon.

Data as of 30 Oct 2026, 05:16 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.07.1
Patch
Available – fixed in 6.1.1_4, 4.8.4_2
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenvwrapper to 6.1.1_4 or 4.8.4_2.

Affected software

ProductAffectedFixed in
Homebrewvirtualenvwrapperpkg:brew/virtualenvwrapperOther threatsAffected
  • >=4.8.4 <4.8.4_2
  • >=6.1.0 <6.1.1_4
Fixed in
  • 4.8.4_2
  • 6.1.1_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in virtualenv versions 4.8.4_2 and 6.1.1_4. Users should upgrade to these or later versions to mitigate this vulnerability. The vendor advisory confirms the fix status. No additional mitigation is required if the environment is updated. Avoid using older bash compatibility modes or exporting PS1 in shells as a temporary measure.

Description

CVE-2026-113723 is a vulnerability in virtualenv's bash activation prompt handling under older bash compatibility modes (4.2 and lower). An attacker who can supply the prompt text to virtualenv can craft it so that it becomes executable shell syntax when the environment is activated and the prompt is drawn. This affects POSIX activation scripts and certain shells like dash when PS1 is exported. The vulnerability was introduced in virtualenv 20.0.0b1 and 21.14.7 and fixed in 4.8.4_2 and 6.1.1_4.

References

Community reviews

Loading reviews…