Skip to main content
CVE-2026-113726VulnerabilityPublished Updated

Virtualenvwrapper: virtualenv activate runs commands from the environment name in zsh with PROMPT_SUBST

Affects virtualenvwrapperSource GCVE Database

0
Compare
Authoritative record:CVE-2026-113726· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 6.1.1_3 or 4.8.4_2 soon.

Data as of 30 Oct 2026, 05:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.8
Patch
Available – fixed in 6.1.1_3, 4.8.4_2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenvwrapper to 6.1.1_3 or 4.8.4_2.

Affected software

ProductAffectedFixed in
Homebrewvirtualenvwrapperpkg:brew/virtualenvwrapperOther threatsAffected
  • >=4.8.4 <4.8.4_2
  • >=6.1.0 <6.1.1_3
Fixed in
  • 4.8.4_2
  • 6.1.1_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade virtualenvwrapper to version 4.8.4_2 or 6.1.1_3 or later where the issue is fixed. Alternatively, set the environment variable VIRTUAL_ENV_DISABLE_PROMPT=1 before sourcing the activate script to prevent modification of PS1, or disable PROMPT_SUBST in zsh by running 'unsetopt prompt_subst' if it is not needed. Verify environment names before activation to avoid malicious payloads.

Description

A command injection vulnerability exists in virtualenvwrapper's activate script when used with zsh shells that have the PROMPT_SUBST option enabled. The environment name used in the shell prompt (PS1) is not properly escaped, allowing command substitution syntax in the environment name to be executed each time the prompt is drawn. This affects virtualenvwrapper versions up to and including 4.8.4_2 and 6.1.1_3. The issue is fixed in version 4.8.4_2 and 6.1.1_3.

References

Community reviews

Loading reviews…