Skip to main content
CVE-2026-113725VulnerabilityPublished Updated

Virtualenvwrapper: virtualenv bash activate runs commands from an environment name with a backslash before $

Affects virtualenvwrapperSource GCVE Database

0
Compare
Authoritative record:CVE-2026-113725· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 6.1.1_4 or 4.8.4_2 soon.

Data as of 30 Oct 2026, 05:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.1.1_4, 4.8.4_2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenvwrapper to 6.1.1_4 or 4.8.4_2.

Affected software

ProductAffectedFixed in
Homebrewvirtualenvwrapperpkg:brew/virtualenvwrapperOther threatsAffected
  • >=4.8.4 <4.8.4_2
  • >=6.1.0 <6.1.1_4
Fixed in
  • 4.8.4_2
  • 6.1.1_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in virtualenvwrapper version 21.14.7 (including 4.8.4_2 and 6.1.1_4). Users should upgrade to these fixed versions. Alternatively, setting the environment variable VIRTUAL_ENV_DISABLE_PROMPT=1 before sourcing 'activate' disables prompt modification and prevents exploitation. Another mitigation is to run 'shopt -u promptvars' if prompt expansion is not needed. Users should also verify environment names before sourcing 'activate' to avoid untrusted inputs.

Description

A command injection vulnerability exists in the bash activate script of virtualenvwrapper where environment names containing backslashes before dollar signs can execute arbitrary commands each time the shell prompt is drawn. This occurs because the script escapes special characters only for one of bash's two PS1 processing passes, allowing crafted environment names to run commands with the user's privileges. The issue affects virtualenvwrapper versions before 4.8.4_2 and 6.1.1_4 and was fixed in 21.14.7. Mitigations include disabling prompt modification or avoiding untrusted environment names.

References

Community reviews

Loading reviews…