CVE-2026-113714: virtualenv · Downloaded wheel selection and caching precede verification
Affects poetrySource GCVE Database
Not known to be exploited · CVSS 2.3 Low : upgrade to 2.5.1_1 when convenient.
Data as of 27 Oct 2026, 06:45 UTC
- Patch
- Available – fixed in 2.5.1_1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade poetry to 2.5.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpoetrypkg:brew/poetryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in virtualenv version 2.5.1_1, which changes the wheel download process to first download and verify wheels in a private temporary directory before adding them to the reusable cache. Users should upgrade to version 2.5.1_1 or later to remediate this vulnerability.
Description
CVE-2026-113714 is a vulnerability in virtualenv's wheel download and caching mechanism. The issue arises because downloaded wheel files are placed directly into a reusable cache before verification completes. Verification uses pip's textual output to select the file to check, which can be manipulated by a malicious package index. This can cause a modified wheel to be cached and reused despite failing verification, potentially leading to the use of tampered packages. The flaw does not bypass TLS or affect the default PyPI setup and was fixed in virtualenv version 2.5.1_1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-494p-63j8-28p3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113714 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3430 (opens in a new tab)
- github.com/pypa/virtualenv/commit/7babec66e043e1cc8bc66869a063653898719d96 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)