Skip to main content
VulnerabilityPublished Updated

CVE-2026-113722: virtualenv · Generated POSIX console launchers interpret destination paths as shell syntax

Affects virtualenvwrapperSource GCVE Database

0
Compare
Authoritative record:CVE-2026-113722· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 6.1.1_4 or 4.8.4_2 soon.

Data as of 30 Oct 2026, 05:18 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.8
Patch
Available – fixed in 6.1.1_4, 4.8.4_2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade virtualenvwrapper to 6.1.1_4 or 4.8.4_2.

Affected software

ProductAffectedFixed in
Homebrewvirtualenvwrapperpkg:brew/virtualenvwrapperOther threatsAffected
  • >=4.8.4 <4.8.4_2
  • >=6.1.0 <6.1.1_4
Fixed in
  • 4.8.4_2
  • 6.1.1_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in virtualenv versions 4.8.4_2 and 6.1.1_4. Users and administrators should upgrade to these or later versions to mitigate this vulnerability. Since pip's vendored distlib can still generate vulnerable wrappers during later pip installs or upgrades, users should also ensure pip is updated to a version that includes the fix or apply additional mitigations as recommended by the pip maintainers. No other immediate actions are required if the environment is upgraded. Avoid running generated POSIX console launchers from untrusted or attacker-controlled paths.

Description

A vulnerability in virtualenv's POSIX console launcher generation allows attacker-controlled destination paths to be interpreted as shell syntax. This occurs because the interpreter path is not properly escaped in the shell wrapper, enabling shell expansions like $(...) to execute when the generated launcher is run. The issue affects POSIX console scripts generated by the app-data seeder or pip when the interpreter path requires a shell wrapper. Windows executable launchers are not affected. An attacker must supply a crafted environment destination path and the user must run the generated launcher for exploitation. The vulnerability is fixed in virtualenv versions 4.8.4_2 and 6.1.1_4.

References

Community reviews

Loading reviews…