Skip to main content
VulnerabilityPublished Updated

CVE-2024-20978: Uncontrolled Resource Consumption

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-20978· Medium 4.9

Not known to be exploited · CVSS 4.9 Medium : upgrade to 8.2.1 or 8.0.36 when convenient.

Data as of 4 Nov 2026, 17:42 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (oracle)CVSS 3.14.9
Patch
Available – fixed in 8.2.1, 8.0.36
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade mysql/mysql-server to 8.2.1 or 8.0.36.

Affected software

ProductAffectedFixed in
Mysqlmysql/mysql-serverpkg:deb/mysql/mysql-serverOther threatsAffected
  • <8.0.36
  • <8.2.1
Fixed in
  • 8.0.36
  • 8.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Oracle has released patches for this vulnerability as part of the January 2024 Critical Patch Update. Users should apply the relevant patches promptly to affected MySQL Server versions 8.0.35 and prior, and 8.2.0 and prior. Oracle strongly recommends remaining on actively supported versions and applying Critical Patch Updates without delay to mitigate this and other vulnerabilities.

Description

CVE-2024-20978 is a vulnerability in the Oracle MySQL Server's optimizer component affecting versions 8.0.35 and prior, and 8.2.0 and prior. It allows a high-privileged attacker with network access to cause a denial of service by hanging or crashing the MySQL Server. The vulnerability has a CVSS 3.1 base score of 4.9, indicating a medium severity impact focused on availability.

References

Community reviews

Loading reviews…