Skip to main content
CVE-2026-50750VulnerabilityPublished Updated

Org.apache.activemq:activemq broker: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have a Denial of

Affects org.apache.activemq:activemq-brokerSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-50750· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.19.8 soon.

Data as of 4 Nov 2026, 20:36 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.19.8, 6.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.activemq:activemq-broker and org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all to 5.19.8; org.apache.activemq:activemq-broker and org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all to 6.2.7.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:activemq-brokerAffected
  • >=5.19.7 <5.19.8
  • =5.19.7
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-brokerAffected
  • >=6.2.6 <6.2.7
  • =6.2.6
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:apache-activemqAffected
  • >=5.19.7 <5.19.8
  • =5.19.7
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.2.6 <6.2.7
  • =6.2.6
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:activemq-allAffected
  • >=5.19.7 <5.19.8
  • =5.19.7
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-allAffected
  • >=6.2.6 <6.2.7
  • =6.2.6
Fixed in
  • 6.2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ Broker to version 5.19.8 or 6.2.7 or later, where this issue is fixed. Since a patch is available, applying the official fix is the recommended mitigation.

Description

A Denial of Service (DoS) vulnerability exists in Apache ActiveMQ Broker versions 5.19.7 up to but not including 5.19.8, and 6.2.6 up to but not including 6.2.7. An unauthenticated attacker can cause an out-of-memory (OOM) condition by sending repeated BrokerInfo commands without sending a ConnectionInfo, leading to broker crash. The issue is fixed in versions 5.19.8 and 6.2.7.

References

Community reviews

Loading reviews…