CVE-2024-31211: Wordpress · Remote Code Execution in `WP_HTML_Token`
Affects wordpressSource GCVE Database
Not known to be exploited : upgrade to 6.4.2 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 2.7% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.4.2
Exploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade wordpress to 6.4.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiwordpresspkg:bitnami/wordpressOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected WordPress installations to version 6.4.2 or later, where this vulnerability has been fixed. No additional mitigation steps are indicated beyond applying the official patch.
Description
A critical remote code execution vulnerability exists in WordPress due to unsafe unserialization of WP_HTML_Token class instances via its __destruct() method. This flaw affects WordPress versions from 6.4.0 up to but not including 6.4.2. The issue was fixed in WordPress 6.4.2 released on December 6th, 2023.