Skip to main content
CVE-2024-31210VulnerabilityPublished Updated

CVE-2024-31210: Wordpress · PHP file upload bypass via Plugin installer

Affects wordpressSource GCVE Database

0

Not known to be exploited · fixed in 6.0.7 : patch wordpress soon.

Data as of 26 Oct 2026, 06:26 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.7, 5.9.9, 5.8.9 +17

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Bitnamiwordpresspkg:bitnami/wordpressOther threatsAffected
  • <4.1.40
  • >=4.2.0 <4.2.37
  • >=4.3.0 <4.3.33
  • >=4.4.0 <4.4.32
  • >=4.5.0 <4.5.31
  • >=4.6.0 <4.6.28
  • >=4.7.0 <4.7.28
  • >=4.8.0 <4.8.24
  • >=4.9.0 <4.9.25
  • >=5.0.0 <5.0.21
  • >=5.1.0 <5.1.18
  • >=5.2.0 <5.2.20
  • >=5.3.0 <5.3.17
  • >=5.4.0 <5.4.15
  • >=5.5.0 <5.5.14
  • >=5.6.0 <5.6.13
  • >=5.7.0 <5.7.11
  • >=5.8.0 <5.8.9
  • >=5.9.0 <5.9.9
  • >=6.0.0 <6.0.7
  • >=6.1.0 <6.1.5
  • >=6.2.0 <6.2.4
  • >=6.3.0 <6.3.3
  • >=6.4.0 <6.4.3
Fixed in
  • 4.1.40
  • 4.2.37
  • 4.3.33
  • 4.4.32
  • 4.5.31
  • 4.6.28
  • 4.7.28
  • 4.8.24
  • 4.9.25
  • 5.0.21
  • 5.1.18
  • 5.2.20
  • 5.3.17
  • 5.4.15
  • 5.5.14
  • 5.6.13
  • 5.7.11
  • 5.8.9
  • 5.9.9
  • 6.0.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been applied in WordPress version 6.4.3 and backported to many earlier versions. Site administrators should upgrade to one of these fixed versions. As a workaround, setting the DISALLOW_FILE_MODS constant to true will prevent any plugin uploads and thus mitigate the vulnerability. Sites where FTP credentials are not requested or are accessible to the administrator are not affected. No additional action is required if the site is already configured with DISALLOW_FILE_MODS=true.

Description

A vulnerability in WordPress allows an administrator-level user to bypass file upload restrictions on the plugin installer screen, potentially enabling remote code execution (RCE) under specific conditions. This occurs when FTP credentials are required for plugin installation and the DISALLOW_FILE_EDIT constant is set to true, allowing a non-zip file to remain temporarily accessible in the Media Library. The issue affects single site installations for Administrator users and Multisite installations for Super Admin users, but not lower privilege users. Sites with DISALLOW_FILE_MODS set to true or where FTP credentials are not required or accessible are not affected. The vulnerability was fixed in WordPress 6.4.3 and backported to many earlier versions.

References

Community reviews

Loading reviews…