CVE-2026-6668 is a vulnerability in PgBouncer where an unauthenticated remote attacker can trigger an integer overflow in the packet buffer growth logic by sending large input. This overflow causes an infinite loop that saturates a CPU core and stalls all pooled connections, resulting in a Denial of Service (DoS). PgBouncer typically acts as a connection pooler accessible by client applications, and this flaw can disrupt database availability without requiring authentication. The issue is rated as Important severity by Red Hat. Mitigation involves restricting network access to PgBouncer to trusted clients or localhost using firewall rules.
A security vulnerability in the gstreamer1-plugins-base package for Red Hat Enterprise Linux 8.6 allows arbitrary code execution due to a buffer overflow in OGG file parsing. This issue is identified as CVE-2026-18297 and is rated with high severity by Red Hat Product Security. An update addressing this vulnerability is available for affected Red Hat Enterprise Linux 8.6 variants.
A heap buffer under-read vulnerability (CVE-2025-5278) exists in the GNU Coreutils sort utility as distributed in Red Hat Enterprise Linux 8. This flaw involves improper handling of key specifications in the sort command, potentially leading to memory safety issues. Red Hat has released an update to address this moderate severity security issue in coreutils packages for multiple architectures.
A security vulnerability (CVE-2026-55193) in FreeRDP, a free implementation of the Remote Desktop Protocol client, allows remote code execution or causes client crashes when connecting via a malicious TS Gateway. This issue affects Red Hat Enterprise Linux 8 and related products. Red Hat has released an important security update to address this vulnerability.
A security update for Rust addresses a denial of service vulnerability in libgit2 caused by a heap out-of-bounds read triggered by a malicious Git server. This issue is tracked as CVE-2026-53587 and affects Red Hat Enterprise Linux 9.6 Extended Update Support and related variants. The vulnerability could allow an attacker controlling a Git server to cause a denial of service in applications using libgit2. Red Hat has released an important security update to fix this issue.
A security vulnerability (CVE-2026-73194) has been identified in the perl-DBI package, which provides the standard database interface module for Perl. The flaw involves a heap out-of-bounds write caused by an unvalidated numeric placeholder. Red Hat has issued an important security update for perl-DBI version 1.641 to address this issue in Red Hat Enterprise Linux 8 across multiple architectures.
A security vulnerability in the libtiff library used for manipulating TIFF files allows arbitrary code execution via the process_command_opts() function. This issue is identified as CVE-2026-52490 and affects Red Hat Enterprise Linux 8 and related products. Red Hat has issued a security advisory and released updated libtiff packages to address this vulnerability.
A security vulnerability (CVE-2026-16313) in the sg3_utils package for Red Hat Enterprise Linux 10.0 Extended Update Support allows arbitrary command execution via udev property injection in the sg_inq --export command. This issue has been addressed in an update provided by Red Hat. The vulnerability is rated as having an Important security impact by Red Hat Product Security.
CVE-2026-93450 is a vulnerability in go-openapi/swag jsonutils before version 0.27.1 involving uncontrolled recursion in ordered JSON marshal and unmarshal operations. The flaw relates to improper handling of recursive data structures during JSON processing.
A denial of service vulnerability exists in the perl-Net-DNS package due to unbounded recursion triggered by misplaced TSIG records. This flaw can cause the DNS resolver modules to consume excessive resources, potentially leading to service disruption. The issue is tracked as CVE-2026-81928 and affects Red Hat Enterprise Linux 9 and related variants. Red Hat has issued a security update to address this vulnerability.
A vulnerability in Apache Thrift affects Red Hat AI Base Images 3.3.3 (CUDA), allowing remote attackers to cause a denial of service by sending specially crafted highly compressed data. This improper handling of data amplification leads to resource exhaustion and service disruption. The issue impacts Red Hat products utilizing vulnerable Thrift bindings, including Red Hat OpenShift AI. No fix is currently available for this vulnerability.