A denial of service vulnerability exists in the GraphQL-core library used by Moto due to a memory leak triggered by aborted validations when the number of validation errors exceeds the max_errors limit (default 100). This causes a shared exception instance to accumulate traceback frames, retaining memory indefinitely and leading to memory exhaustion. The issue affects Moto versions >=5.2.3_1 and <5.2.5 and is fixed in version 5.2.5.
A vulnerability in joserfc 1.7.4 allows attacker-controlled segments to be allocated in memory before size validation rejects them. This occurs because the library calls bytes.split() on the input before checking its length, causing an additional allocation roughly the size of the payload. This undermines the intended size guard and can lead to excessive memory usage. The issue is fixed in version 5.2.5.
The joserfc library's decrypt_json() function for JWE General JSON Serialization does not limit the number of recipients in the 'recipients' array. This allows an attacker to craft a JWE with an unbounded number of recipients, causing the library to perform a costly RSA private-key decryption operation for each recipient. This results in a CPU exhaustion denial-of-service (DoS) vulnerability with a high severity score (CVSS 7.5). The library's existing mitigation option verify_all_recipients=False does not reduce CPU usage, as all recipients are decrypted before this flag is checked. A fix is available in version 5.2.3_1.
CVE-2026-119209 is a vulnerability in the pdfalyzer tool (pypdf library) that allows an attacker to craft a PDF file with cross-reference streams causing large memory usage when parsed. This can lead to denial of service due to resource exhaustion. The issue affects versions starting from 1.16.1. A fix is available in pypdf version 6.21.3. If upgrading is not immediately possible, applying the changes from the referenced pull request #4269 is recommended as a workaround.
CVE-2026-119208 is a vulnerability in pypdf (pdfalyzer) that allows an attacker to craft an encrypted PDF file with a manipulated /Count value, causing excessive runtimes and large memory usage when accessing the page count. This can lead to denial of service conditions due to resource exhaustion. The issue affects versions starting from 1.16.1 and has been fixed in pypdf version 6.21.3.
CVE-2026-119207 is a high-severity vulnerability in pdfalyzer's pypdf component that allows an attacker to craft a malicious PDF causing large memory usage when an invalid dictionary is loaded in strict mode. This can lead to resource exhaustion. The issue has been fixed in pypdf version 6.21.3. If upgrading is not immediately possible, applying the changes from the referenced pull request #4265 is recommended as a workaround.
CVE-2026-119206 is a vulnerability in the pdfalyzer product related to the pypdf library. It allows an attacker to craft a PDF file that causes long runtimes when retrieving page labels. This can lead to performance degradation or denial of service. The issue affects versions of pdfalyzer using pypdf from 1.16.1 onward. A fix is available in pypdf version 6.21.3. If upgrading is not immediately possible, applying the changes from pull request #4251 is recommended as a workaround.
CVE-2026-119205 is a vulnerability in pdfalyzer's pypdf component where cloning a DictionaryObject can cause an infinite loop. This flaw allows an attacker to craft a malicious PDF that triggers this behavior. The issue has been fixed in pypdf version 6.21.4. Users unable to upgrade immediately can apply the patch from the referenced pull request.
CVE-2026-119204 is a vulnerability in the pdfalyzer product related to the pypdf library. It allows an attacker to craft a malicious PDF that causes large memory usage during parsing of the page tree with many shared resources. This can lead to high resource consumption on the affected system. A fix is available in pypdf version 6.21.4. If upgrading is not possible, applying the changes from pull request #4290 is recommended as a workaround.
A vulnerability in pdfalyzer (pypdf) allows an attacker to craft a PDF file that causes an infinite loop when the parser encounters an incomplete file missing a trailer during the standard cross-reference table trailer search.
CVE-2026-119197 is a denial-of-service vulnerability in pyasn1 versions 0.6.4 and earlier affecting the decoding of binary-encoded ASN.1 REAL values with large mantissas. The decoding process has quadratic time complexity due to inefficient byte-wise processing, causing excessive CPU consumption. This impacts BER, CER, and DER decoders that use the vulnerable RealPayloadDecoder. The vulnerability allows an attacker who can supply crafted ASN.1 input containing REAL values to cause CPU exhaustion during decoding. The issue is fixed in pyasn1 version 0.6.5 by replacing the inefficient loop with a more efficient integer conversion. Until patched, applications should limit or reject attacker-controlled ASN.1 input with REAL values.
CVE-2026-119196 affects pyasn1 through version 0.6.4, where decoding constructed BIT STRING values with many fragments causes quadratic CPU consumption due to repeated shifting and copying of accumulated data. This can lead to CPU exhaustion and denial of service if attacker-controlled ASN.1 data with many fragments is decoded. The vulnerability impacts BER and CER decoders, and a permissive schema-driven DER decoder path. No confidentiality or integrity impact is reported. The CVSS v3.1 base score is 7.5 (high severity).
A denial of service vulnerability exists in pyasn1 version 0.6.4 and earlier, affecting the decoding of constructed OCTET STRINGs and indefinite-length ANY types. The decoder's string reassembly process exhibits quadratic time complexity due to repeated copying of accumulated fragments, leading to excessive CPU consumption. This can be exploited by an attacker supplying crafted ASN.1 input to cause CPU exhaustion. The issue affects BER and CER decoding paths and certain non-conforming DER inputs. No confidentiality or integrity impact is reported.
CVE-2026-119194 is a high-severity vulnerability in the pyasn1 library used by kimi-cli, where schemaless decoding of BER, CER, or DER data with many distinct long tag IDs causes quadratic CPU usage. This can lead to excessive CPU consumption and reduced availability when processing attacker-controlled inputs. The vulnerability affects versions >=0.56. No confidentiality or integrity impacts have been observed.