A critical vulnerability (CVE-2026-90970) in GitLab AI Gateway allows an authenticated user with Duo Agent Platform access to escape the prompt template sandbox via a crafted flow configuration, enabling arbitrary command execution. This affects versions from 18.1.6 up to but not including 19.2.4, 19.3 up to but not including 19.3.2, and 19.4 up to but not including 19.4.1. The issue has been fixed in versions 19.2.4, 19.3.2, and 19.4.1.
A vulnerability in GitLab EE versions from 18.7 up to but not including 19.2.7, 19.3 up to but not including 19.3.3, and 19.4 up to but not including 19.4.1 could allow an authenticated user to access sensitive CI/CD variable values via debug-mode job traces through the Duo AI troubleshooting feature due to missing authorization checks. This issue has been remediated in versions 19.2.7, 19.3.3, and 19.4.1.
A critical integer overflow vulnerability in GitLab CE/EE versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 could allow an authenticated user to execute arbitrary code on the server. The flaw occurs when compiling a specially crafted regular expression in a CI/CD configuration. GitLab has released patches to remediate this issue.
A vulnerability in GitLab CE/EE versions from 16.6 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 could allow unauthorized users to view project import source information due to a missing authorization check. This issue has been remediated in the specified fixed versions.
A vulnerability in GitLab Enterprise Edition versions from 18.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 could allow sensitive information disclosure due to improper handling of upstream requests in virtual registries. This issue has been remediated by GitLab in the specified fixed versions. The vulnerability is classified as CWE-522 and has a CVSS 3.1 vector indicating network attack vector, low attack complexity, low privileges required, no user interaction, unchanged scope, limited confidentiality impact, no integrity impact, and low availability impact. No known exploits in the wild have been reported.
GitLab Enterprise Edition versions from 19.1 before 19.1.3 and 19.2 before 19.2.1 contain a vulnerability that allows an authenticated user to bypass administrator-configured tool governance policies due to improper authorization enforcement during token generation. This issue affects integrity but does not impact confidentiality or availability. The vulnerability has been remediated in versions 19.1.3 and 19.2.1. No known exploits have been reported in the wild.
An issue has been discovered in GitLab EE that allows for cross-site-scripting attack and content security policy bypass in a user's browser under specific conditions, affecting all versions from 16.6 before 17.9.7, 17.10 before 17.10.5, and 17.11 before 17.11.1.
An authorization vulnerability exists in GitLab versions 14.0 prior to 16.6.6, 16.7 prior to 16.7.4, and 16.8 prior to 16.8.1. An unauthorized attacker is able to assign arbitrary users to MRs that they created within the project