CVE-2026-16553: GitLab Has Remediated an Issue
Affects gitlabSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium · fixed in 19.2.1 : update gitlab when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 19.2.1, 19.1.3, 19.0.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gitlab-org/gitlab to 19.2.1, 19.1.3 or 19.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubgitlab-org/gitlabpkg:github/gitlab-org/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
GitLab has released official fixes for this vulnerability in versions 19.0.5, 19.1.3, and 19.2.1. Users should upgrade affected GitLab EE instances to these versions or later to remediate the issue. Patch status is confirmed by the vendor advisory embedded in the description.
Description
A vulnerability in GitLab Enterprise Edition versions from 18.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 could allow sensitive information disclosure due to improper handling of upstream requests in virtual registries. This issue has been remediated by GitLab in the specified fixed versions. The vulnerability is classified as CWE-522 and has a CVSS 3.1 vector indicating network attack vector, low attack complexity, low privileges required, no user interaction, unchanged scope, limited confidentiality impact, no integrity impact, and low availability impact. No known exploits in the wild have been reported.