A high severity vulnerability affects generator-jhipster versions from 4.5.2 up to but not including 6.3.1. The issue arises because generated code uses repository configurations that download dependencies over HTTP instead of HTTPS, exposing Gradle users to potential man-in-the-middle attacks during build time. Maven users are advised to upgrade to version 6.3.0 or later, and Gradle users to 6.3.1 or later. Alternatively, users should replace any HTTP repository URLs with HTTPS to mitigate the risk.