Skip to main content
VulnerabilityPublished Updated

High severity vulnerability that affects generator-jhipster

Affects jhipsterSource GCVE Database

0

CVSS 8.1 High : upgrade to 6.3.1 soon.

Data as of 26 Oct 2026, 16:20 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade jhipster to 6.3.1.

Affected software

ProductAffectedFixed in
Homebrewjhipsterpkg:brew/jhipsterOther threatsAffected
  • >=4.5.2 <6.3.1
Fixed in
  • 6.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available: Maven users should upgrade to version 6.3.0 or later, and Gradle users to 6.3.1 or later. If upgrading is not possible, users must replace all HTTP repository URLs in build files (e.g., build.gradle or pom.xml) with their HTTPS equivalents to prevent man-in-the-middle attacks.

Description

A high severity vulnerability affects generator-jhipster versions from 4.5.2 up to but not including 6.3.1. The issue arises because generated code uses repository configurations that download dependencies over HTTP instead of HTTPS, exposing Gradle users to potential man-in-the-middle attacks during build time. Maven users are advised to upgrade to version 6.3.0 or later, and Gradle users to 6.3.1 or later. Alternatively, users should replace any HTTP repository URLs with HTTPS to mitigate the risk.

References

Community reviews

Loading reviews…