A buffer overflow vulnerability exists in the Brotli decoder component of Google Brotli versions 1.0.3 through 1.2.0. This flaw allows remote unauthenticated attackers to corrupt adjacent memory, potentially leading to sensitive data disclosure, denial of service, or arbitrary code execution. Users should update affected Brotli libraries or binaries to fixed versions 1.0.10, 1.1.1, or 1.2.1. Additionally, the vulnerability affects the locust product in versions >=2.2.1 <2.18.4 and >=2.23.1 <2.47.0_1, with fixes available in 2.18.4 and 2.47.0_1.