Skip to main content
VulnerabilityPublished

CVE-2026-111497: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

Affects locustSource GCVE Database

0
Authoritative record:CVE-2026-111497· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 2.47.0_1 or 2.18.4 as a priority.

Data as of 26 Oct 2026, 18:59 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.47.0_1, 2.18.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade locust to 2.47.0_1 or 2.18.4.

Affected software

ProductAffectedFixed in
Homebrewlocustpkg:brew/locustOther threatsAffected
  • >=2.2.1 <2.18.4
  • >=2.23.1 <2.47.0_1
Fixed in
  • 2.18.4
  • 2.47.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update affected Brotli libraries to versions 1.0.10, 1.1.1, or 1.2.1. For the locust product, update to versions 2.18.4 or 2.47.0_1 or later. Applying these updates fully mitigates the vulnerability.

Description

A buffer overflow vulnerability exists in the Brotli decoder component of Google Brotli versions 1.0.3 through 1.2.0. This flaw allows remote unauthenticated attackers to corrupt adjacent memory, potentially leading to sensitive data disclosure, denial of service, or arbitrary code execution. Users should update affected Brotli libraries or binaries to fixed versions 1.0.10, 1.1.1, or 1.2.1. Additionally, the vulnerability affects the locust product in versions >=2.2.1 <2.18.4 and >=2.23.1 <2.47.0_1, with fixes available in 2.18.4 and 2.47.0_1.

References

Community reviews

Loading reviews…