Skip to main content
CVE-2025-6176VulnerabilityPublished Updated

Locust: Scrapy is vulnerable to a denial of service (DoS) attack due to flaws in brotli decompression implementation

Affects locustSource GCVE Database

0
Authoritative record:CVE-2025-6176· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2.42.1_1 or 2.18.4 soon.

Data as of 26 Oct 2026, 18:59 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.42.1_1, 2.18.4
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade locust to 2.42.1_1 or 2.18.4.

Affected software

ProductAffectedFixed in
Homebrewlocustpkg:brew/locustOther threatsAffected
  • >=2.2.1 <2.18.4
  • >=2.23.1 <2.42.1_1
Fixed in
  • 2.18.4
  • 2.42.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading Scrapy to versions 2.18.4 or 2.42.1_1 or later, which include the security enhancements from brotli v1.2.0. Since a patch is available, remediation should be performed promptly to prevent denial of service conditions.

Description

Scrapy versions up to 2.13.3 are vulnerable to a denial of service (DoS) attack due to a flaw in the brotli decompression implementation. The existing protection against decompression bombs does not mitigate the brotli variant, allowing remote servers to cause excessive memory consumption and crash clients with less than 80GB of available memory. This vulnerability is addressed by security enhancements introduced in brotli version 1.2.0.

References

Community reviews

Loading reviews…