CVE-2024-6221: Locust · Flask-CORS allows the `Access-Control-Allow-Private-Network` CORS header to be set to true by default
Affects locustSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 2.31.4_1 soon.
Data as of 1 Nov 2026, 22:57 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.31.4_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade locust to 2.31.4_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewlocustpkg:brew/locustOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Locust to a version later than or equal to 2.31.4_1 where the issue is fixed. Applying the official patch will prevent the Access-Control-Allow-Private-Network header from being set to true by default, eliminating the exposure risk.
Description
CVE-2024-6221 is a high-severity vulnerability in the Locust product related to the flask-cors library version 4.0.1. It causes the Access-Control-Allow-Private-Network CORS header to be set to true by default without configuration options. This misconfiguration can expose private network resources to unauthorized external access, increasing the risk of data breaches and network intrusions. The vulnerability affects Locust versions from 2.2.1 up to but not including 2.31.4_1. A patch is available to address this issue.
References
- nvd.nist.gov/vuln/detail/CVE-2024-6221 (opens in a new tab)
- github.com/corydolphin/flask-cors/issues/362 (opens in a new tab)
- github.com/corydolphin/flask-cors/pull/363 (opens in a new tab)
- github.com/corydolphin/flask-cors/pull/368 (opens in a new tab)
- github.com/corydolphin/flask-cors/commit/03aa3f8e2256437f7bad96422a747b98ab5e31bf (opens in a new tab)
- github.com/corydolphin/flask-cors/commit/7ae310c56ac30e0b94fb42129aa377bf633256ec (opens in a new tab)
- github.com/corydolphin/flask-cors/commit/c8514760cf03fcce16d77f6db7007aad429c4548 (opens in a new tab)
- github.com/corydolphin/flask-cors (opens in a new tab)
- github.com/corydolphin/flask-cors/releases (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/flask-cors/PYSEC-2024-260.yaml (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/flask-cors/PYSEC-2024-71.yaml (opens in a new tab)
- huntr.com/bounties/a42935fc-6f57-4818-bca4-3d528235df4d (opens in a new tab)