OpenClaw versions up to 2026.3.28 allow a workspace .env file to override the bundled plugin trust root directory, potentially enabling an attacker with control over the workspace to influence plugin loading. This vulnerability is rated high severity with a CVSS score of 7.8. The issue is fixed in version 2026.3.31.