Skip to main content
VulnerabilityPublished

CVE-2026-123992: DataEase · Cross-site Scripting

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123992· Medium 5.3

Public exploit available · CVSS 5.3 Medium · fixed in 2.10.28 : patch DataEase as a priority.

Data as of 7 Nov 2026, 19:34 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.3
CNA (VulDB)CVSS 3.14.3
CNA (VulDB)CVSS 3.04.3
CNA (VulDB)CVSS 2.05.0
Patch
Available – fixed in 2.10.28
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
DataEaseAffected
  • 2.10.0 – 2.10.27
28 affected builds
Fixed in–
GitHubdataease/dataeasepkg:github/dataease/dataeaseOther threatsAffected
  • <=2.10.27
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade DataEase to version 2.10.28 or later, which includes the official fix addressing this vulnerability. The vendor's patch replaces blacklist checks with namespace-aware allowlists and applies a restrictive Content Security Policy to SVG responses, effectively mitigating the issue. No additional mitigation steps are required beyond applying the update.

Description

A cross-site scripting (XSS) vulnerability exists in DataEase up to version 2.10.27 in the StaticResourceServer.validateSvgContent function of the SVG Handler component. This flaw allows remote attackers to execute script code by manipulating SVG content. The issue is resolved in version 2.10.28 with improved SVG security measures including namespace-aware allowlists and restrictive Content Security Policy.

References

Community reviews

Loading reviews…