Skip to main content
VulnerabilityPublished Updated

CVE-2026-21714: Node.js HTTP/2 servers · Memory Leak Occurs

Affects nodeSource GCVE Database

0
Authoritative record:CVE-2026-21714· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 25.8.2 : update node when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.8.2, 24.14.1, 22.22.2 +1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade node to 25.8.2, 24.14.1, 22.22.2 or 20.20.2.

Affected software

ProductAffectedFixed in
Bitnaminodepkg:bitnami/nodeOther threatsAffected
  • <20.20.2
  • >=21.0.0 <22.22.2
  • >=23.0.0 <24.14.1
  • >=25.0.0 <25.8.2
Fixed in
  • 20.20.2
  • 22.22.2
  • 24.14.1
  • 25.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to Node.js versions 20.20.2 or later, 22.22.2 or later, 24.14.1 or later, and 25.8.2 or later to remediate this issue. No additional mitigation steps are indicated beyond applying the official fixes.

Description

A memory leak vulnerability exists in Node.js HTTP/2 servers when a client sends WINDOW_UPDATE frames on stream 0 that cause the flow control window to exceed the maximum allowed value. Although the server responds with a GOAWAY frame, the associated Http2Session object is not properly cleaned up, leading to resource leakage. This affects multiple Node.js versions including 20, 21, 23, and 25 within specified version ranges.

References

Community reviews

Loading reviews…