CVE-2026-90580: FlowiseAI Flowise · Server-Side Request Forgery
Affects FlowiseSource GCVE Database
Public exploit available · CVSS 5.3 Medium : upgrade to 3.0.3 as a priority.
Data as of 29 Oct 2026, 10:10 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 13 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade flowiseai/Flowise to 3.0.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade FlowiseAI Flowise to version 3.1.3 or later to remediate this vulnerability. Since the affected versions are no longer supported, upgrading is the recommended and only effective mitigation. No other vendor advisories indicate alternative mitigations or temporary fixes.
Description
A vulnerability was found in FlowiseAI Flowise up to 3.0.2. This vulnerability affects the function axios.post of the file packages/server/src/controllers/evaluations/index.ts of the component Evaluations Endpoint. The manipulation of the argument Host/X-Forwarded-Proto results in server-side request forgery. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 3.1.3 is able to resolve this issue. The patch is identified as 700137738bcaebefd4709021f6d6b0abcd7df0ac. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.
References
- nvd.nist.gov/vuln/detail/CVE-2026-90580 (opens in a new tab)
- github.com/FlowiseAI/Flowise/issues/6687 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/700137738bcaebefd4709021f6d6b0abcd7df0ac (opens in a new tab)
- github.com/FlowiseAI/Flowise (opens in a new tab)
- github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.3 (opens in a new tab)
- vuldb.com/cve/CVE-2026-90580 (opens in a new tab)
- vuldb.com/submit/913327 (opens in a new tab)
- vuldb.com/vuln/403165 (opens in a new tab)
- vuldb.com/vuln/403165/cti (opens in a new tab)