Skip to main content
VulnerabilityPublished

CVE-2026-123025: os-acme-client · An OS Command Injection vulnerability was discovered in the Google Cloud DNS validation module of

Affects os-acme-clientSource GCVE Database

0
Compare
Authoritative record:CVE-2026-123025· Critical 9.4

Not known to be exploited · CVSS 9.4 Critical : upgrade to 4.17 as a priority.

Data as of 5 Nov 2026, 10:30 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 4.09.4
Affects
OPNsense os-acme-client plugin through 4.17
Patch
Available – fixed in 4.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade opnsense/plugins/os-acme-client to 4.17.

Affected software

ProductAffectedFixed in
GitHubopnsense/plugins/os-acme-clientpkg:github/opnsense/plugins/os-acme-clientOther threatsAffected
  • <4.17
Fixed in
  • 4.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict certificate issuance and renewal privileges to trusted users only and monitor for suspicious activity related to the os-acme-client plugin.

Description

An OS Command Injection vulnerability exists in the Google Cloud DNS validation module of the OPNsense os-acme-client plugin through version 4.17. The vulnerability arises because certain user-controlled fields are directly interpolated into shell commands without validation or escaping. A remote authenticated user with privileges to issue or renew certificates via the WebGUI or API can exploit this to execute arbitrary code as root.

References

Community reviews

Loading reviews…