Skip to main content
VulnerabilityPublished Updated

CVE-2026-25087: Apache Arrow · Potential use-after-free when reading IPC file with pre-buffering

Affects apache-arrowSource GCVE Database

0
Compare
Authoritative record:CVE-2026-25087· High 7.0

Not known to be exploited · CVSS 7.0 High : upgrade to 23.0.1 soon.

Data as of 4 Nov 2026, 07:13 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 23.0.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade apache-arrow to 23.0.1.

Affected software

ProductAffectedFixed in
Homebrewapache-arrowpkg:brew/apache-arrowOther threatsAffected
  • >=15.0.0 <23.0.1
Fixed in
  • 23.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should verify if pre-buffering is enabled via RecordBatchFileReader::PreBufferMetadata. If enabled, they should disable pre-buffering or upgrade to Apache Arrow version 23.0.1 or later, where the vulnerability is fixed. Since pre-buffering is disabled by default and not exposed in language bindings, users of those bindings are not vulnerable.

Description

Apache Arrow C++ versions 15.0.0 through 23.0.0 contain a use-after-free vulnerability triggered when reading IPC files with pre-buffering enabled and variadic buffers present. This can cause random crashes or memory corruption. The vulnerability is not present in language bindings like Python or Ruby. Pre-buffering is disabled by default and can be disabled to mitigate risk. A fix is available in version 23.0.1.

References

Community reviews

Loading reviews…