CVE-2026-49265: Oauthlib · Timing Attack Vulnerability in PKCE code_verifier Comparison
Affects confluence-markdown-exporterSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium : upgrade to 5.5.0 when convenient.
Data as of 4 Nov 2026, 08:16 UTC
- Patch
- Available – fixed in 5.5.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade confluence-markdown-exporter to 5.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewconfluence-markdown-exporterpkg:brew/confluence-markdown-exporterOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in version 5.5.0 of confluence-markdown-exporter that replaces the vulnerable string comparison with a constant-time comparison function (hmac.compare_digest()). Users should upgrade to version 5.5.0 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A timing side-channel vulnerability exists in the PKCE implementation of the OAuthlib Authorization Code Grant flow. The vulnerability arises because the code_verifier comparison uses Python's standard '==' operator instead of a constant-time comparison, allowing attackers to measure timing differences and potentially recover the code_verifier. This could lead to account takeover if exploited. The issue affects versions >=5.4.0 and <5.5.0 of the confluence-markdown-exporter product and has been fixed in version 5.5.0.
References
- github.com/oauthlib/oauthlib/security/advisories/GHSA-xpv3-w29h-x7cv (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-49265 (opens in a new tab)
- github.com/oauthlib/oauthlib/pull/963 (opens in a new tab)
- github.com/oauthlib/oauthlib/commit/40b0ab56da3682c2484a4b78bbff309f8025d950 (opens in a new tab)
- github.com/oauthlib/oauthlib (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/oauthlib/PYSEC-2026-4114.yaml (opens in a new tab)