Skip to main content
VulnerabilityPublished

CVE-2026-114605: Apache superset · dnspython is a DNS toolkit for Python

Affects apache-supersetSource GCVE Database

0
Compare
Authoritative record:CVE-2026-114605· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.0.0-r12 soon.

Data as of 5 Nov 2026, 02:11 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 5.0.0-r12, 6.1.0-r8, 2021.38.2-r0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache-superset to 5.0.0-r12; apache-superset to 6.1.0-r8; apache-superset to 2021.38.2-r0.

Affected software

ProductAffectedFixed in
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <5.0.0-r12
Fixed in
  • 5.0.0-r12
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <6.1.0-r8
Fixed in
  • 6.1.0-r8
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.38.2-r0
Fixed in
  • 2021.38.2-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading apache-superset to versions 5.0.0-r12, 6.1.0-r8, or 2021.38.2-r0 or later, as these contain the fix for this vulnerability.

Description

A high-severity security vulnerability (CVE-2026-114605) affects the apache-superset package due to an issue in dnspython, a DNS toolkit for Python. The vulnerability has an impact on availability but does not affect confidentiality or integrity. Fixed versions are available.

References

Community reviews

Loading reviews…