CVE-2026-112396: Apache superset · Pillow is a Python imaging library
Affects apache-supersetSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 2021.38.2-r0 when convenient.
Data as of 5 Nov 2026, 02:01 UTC
- Patch
- Available – fixed in 2021.38.2-r0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade apache-superset to 2021.38.2-r0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade apache-superset to version 2021.38.2-r0 or later, where the vulnerability has been fixed. Since a patch is available, applying this official fix is the recommended mitigation.
Description
A high-severity security vulnerability (CVE-2026-112396) affects the apache-superset package due to an issue in the Pillow Python imaging library. The vulnerability impacts versions of apache-superset prior to 2021.38.2-r0 and can cause a denial of service condition. A patch is available in version 2021.38.2-r0 to address this issue.