wicket-core · Apache Wicket reads texts from the application's resource bundles — a localized label, a css class name — and writes
Affects wicket-coreSource GCVE Database
Not known to be exploited · CVSS 7.6 High.
Data as of 2 Nov 2026, 01:00 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 7.6 |
|---|
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0, which contain fixes for this vulnerability. No other mitigations are indicated or effective given the default Content-Security-Policy behavior. Users of unsupported versions (7.x or older) should upgrade to a supported fixed version.
Description
Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0 contain a vulnerability where texts read from resource bundles are inserted into JavaScript string literals and HTML attributes without proper escaping. This can lead to script injection if the text contains quotes or malicious content. The default Content-Security-Policy in Wicket 9.x and 10.x does not prevent script injection in JavaScript contexts but does prevent inline event handler injection in attribute contexts. Fixed versions are 8.20.0, 9.25.0, and 10.12.0.