Skip to main content
VulnerabilityPublished

CVE-2026-83539: wicket-core · Improper neutralization of input during web page generation in Apache Wicket

Affects wicket-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-83539· High 7.4

Not known to be exploited · CVSS 7.4 High · fixed in 8.20.0 : patch wicket-core soon.

Data as of 2 Nov 2026, 01:00 UTC

CVSS 4.0 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.07.4
Patch
Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threatsAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 where this vulnerability is fixed. Applications using Wicket 9.x or 10.x should ensure the default Content-Security-Policy is enabled and not weakened or disabled, as it prevents script execution from malicious URL schemes. For Wicket 8.x users, upgrading is critical since no Content-Security-Policy protection exists by default. No other configuration changes or mitigations are noted.

Description

Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0 contain a vulnerability in the SmartLinkLabel and SmartLinkMultiLineLabel components. These components convert URLs found in text into clickable links without restricting URL schemes, allowing potentially malicious schemes that execute scripts when a user clicks the link. The default Content-Security-Policy in Wicket 9.x and 10.x mitigates this by requiring a nonce for script execution, but Wicket 8.x lacks this protection. Applications that weaken or disable the default Content-Security-Policy are fully affected. Upgrading to versions 8.20.0, 9.25.0, or 10.12.0 resolves the issue.

References

Community reviews

Loading reviews…