CVE-2026-95863: wicket-core · Improper neutralization of input during web page generation in Apache Wicket
Affects wicket-coreSource GCVE Database
Not known to be exploited · CVSS 7.6 High.
Data as of 2 Nov 2026, 00:59 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 7.6 |
|---|
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 or later, where the vulnerability is fixed by rejecting dangerous characters in component and markup IDs. No other mitigation is indicated, and the default Content-Security-Policy does not prevent this issue. Applications should avoid setting component or markup IDs with special characters that could break JavaScript string literals.
Description
Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0 contain an input neutralization vulnerability during web page generation. The framework improperly escapes component markup IDs and input names when embedding them in JavaScript string literals, allowing injection of script code if these IDs contain certain special characters. This can lead to cross-site scripting (XSS) attacks. The issue is fixed by rejecting dangerous characters in IDs starting from versions 8.20.0, 9.25.0, and 10.12.0.