Skip to main content
VulnerabilityPublished Updated

CVE-2025-54539: Apache.NMS.AMQP · Apache ActiveMQ NMS AMQP Client has a Deserialization of Untrusted Data vulnerability

Affects Apache.NMS.AMQPSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54539· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.4.0 as a priority.

Data as of 4 Nov 2026, 18:18 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Apache.NMS.AMQP to 2.4.0.

Affected software

ProductAffectedFixed in
NuGetApache.NMS.AMQPAffected
  • <2.4.0
Fixed in
  • 2.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache ActiveMQ NMS AMQP Client version 2.4.0 or later, where this vulnerability is fixed. Additionally, projects depending on NMS-AMQP are recommended to migrate away from .NET binary serialization to reduce attack surface. No other mitigations are indicated by the vendor advisory.

Description

Apache ActiveMQ NMS AMQP Client versions up to 2.3.0 contain a critical deserialization of untrusted data vulnerability. This flaw allows malicious AMQP servers to exploit unbounded deserialization logic in the client, potentially leading to arbitrary code execution. Although version 2.1.0 introduced allow/deny list protections, these were bypassable under certain conditions. The issue is resolved in version 2.4.0 and later. Users are advised to upgrade and migrate away from .NET binary serialization for long-term security.

References

Community reviews

Loading reviews…