Skip to main content
VulnerabilityPublished Updated

CVE-2025-59328: Org.apache.fory:fory core: Apache Fory Deserialization of Untrusted Data vulnerability

Affects org.apache.fory:fory-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2025-59328· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.12.2 when convenient.

Data as of 4 Nov 2026, 18:17 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.16.5
Patch
Available – fixed in 0.12.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.fory:fory-core to 0.12.2.

Affected software

ProductAffectedFixed in
Mavenorg.apache.fory:fory-coreAffected
  • <0.12.2
Fixed in
  • 0.12.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users and developers should upgrade to Apache Fory version 0.12.2 or later to remediate this vulnerability. Updating dependency requirements and releasing new software versions that include this fixed version is recommended. Since a patch is available, applying the official fix is the primary mitigation.

Description

Apache Fory versions prior to 0.12.2 contain a vulnerability due to insecure deserialization of untrusted data. This flaw allows a remote attacker to supply a crafted payload that causes excessive CPU consumption during deserialization, leading to denial of service (DoS). Upgrading to version 0.12.2 or later mitigates the issue.

References

Community reviews

Loading reviews…