Skip to main content
VulnerabilityPublished Updated

CVE-2025-58782: Apache Jackrabbit · Core and JCR Commons are vulnerable to Deserialization of Untrusted Data

Affects org.apache.jackrabbit:jackrabbit-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2025-58782· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.22.2 when convenient.

Data as of 4 Nov 2026, 18:17 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.22.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.jackrabbit:jackrabbit-core and org.apache.jackrabbit:jackrabbit-jcr-commons to 2.22.2.

Affected software

ProductAffectedFixed in
Mavenorg.apache.jackrabbit:jackrabbit-coreAffected
  • >=1.0.0 <2.22.2
Fixed in
  • 2.22.2
Mavenorg.apache.jackrabbit:jackrabbit-jcr-commonsAffected
  • >=1.0.0 <2.22.2
Fixed in
  • 2.22.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Apache Jackrabbit Core and JCR Commons installations to version 2.22.2 or later. This version disables JCR lookup through JNDI by default, mitigating the vulnerability. Users who require JNDI URI lookups must explicitly enable this feature and carefully review their usage to avoid exposure.

Description

Apache Jackrabbit Core and JCR Commons versions from 1.0.0 up to 2.22.1 are vulnerable to deserialization of untrusted data via JNDI URI lookups. This vulnerability allows attackers who can supply JNDI URIs to inject malicious references, potentially leading to arbitrary code execution. The issue is fixed in version 2.22.2, where JCR lookup through JNDI is disabled by default. Users relying on this feature must explicitly enable it and carefully review their usage.

References

Community reviews

Loading reviews…