Skip to main content
VulnerabilityPublished Updated

CVE-2025-64439: LangGraph Checkpoint Affected by RCE

Affects langgraph-checkpointSource GCVE Database

0
Compare
Authoritative record:CVE-2025-64439· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 3.0.0 soon.

Data as of 4 Nov 2026, 18:52 UTC

CVSS 4.0 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.07.4
Patch
Available – fixed in 3.0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade langgraph-checkpoint to 3.0.0.

Affected software

ProductAffectedFixed in
PyPIlanggraph-checkpointAffected
  • <3.0.0
Fixed in
  • 3.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade immediately to langgraph-checkpoint version 3.0.0 or later, which includes an allow-list for safe constructor deserialization and removes the unsafe fallback to "json" mode. For users of langgraph-api, upgrading to version 0.5 or later ensures the patched checkpointer is used. No code changes or import modifications are required for compatibility with the fixed version.

Description

LangGraph Checkpoint versions prior to 3.0.0 contain a remote code execution (RCE) vulnerability in the JsonPlusSerializer when deserializing payloads in the "json" serialization mode. This occurs because the deserializer supports a constructor-style format that can execute arbitrary Python code if malicious payloads are deserialized. The vulnerability is fixed in version 3.0.0 by introducing an allow-list for constructor deserialization and deprecating the unsafe "json" fallback mode. Users of langgraph-api version 0.5 or later are also not affected.

References

Community reviews

Loading reviews…