Skip to main content
VulnerabilityPublished Updated

CVE-2026-71553: ApostropheCMS · 2nd-order prototype pollution via PATCH leading to single-request persistent DoS

Affects apostropheSource GCVE Database

0
Authoritative record:CVE-2026-71553· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 4.32.1 soon.

Data as of 28 Oct 2026, 17:11 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.32.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade apostrophe to 4.32.1.

Affected software

ProductAffectedFixed in
npmapostropheAffected
  • <4.32.1
Fixed in
  • 4.32.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in ApostropheCMS version 4.32.1. Users should upgrade to this version to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

ApostropheCMS versions prior to 4.32.1 are vulnerable to a second-order prototype pollution vulnerability via a PATCH request to the article API endpoint. An attacker with a valid editor session can submit a specially crafted payload that overwrites the global toString function, causing a persistent denial-of-service condition in a single request. This vulnerability has a CVSS 4.0 score of 7.1 and is classified as high severity. A fix is available in version 4.32.1.

References

Community reviews

Loading reviews…