CVE-2026-114617: Authlib · ID token can disable its own nonce validation via the nonce_supported claim
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 4.2 Medium : upgrade to 0.23.1_2 when convenient.
Data as of 30 Oct 2026, 08:32 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 4.2 |
|---|
- Patch
- Available – fixed in 0.23.1_2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.23.1_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Authlib to version 0.23.1_2 or later, where the nonce_supported claim is read from server metadata or client configuration rather than from the token payload, preventing tokens from disabling nonce validation. Until upgraded, do not rely on tokens to indicate nonce support. No other mitigations are documented.
Description
Authlib versions prior to 0.23.1_2 contain a vulnerability in the OpenID ID token parsing logic where the nonce validation can be bypassed if the ID token includes a nonce_supported claim set to boolean false. This causes the nonce check to be skipped, allowing replay of a valid signed ID token into an attacker-controlled session, authenticating the attacker as the victim. The issue affects implicit and hybrid flows and direct calls to parse_id_token(), but not the authorization code flow. A fix is available in version 0.23.1_2.
References
- github.com/authlib/authlib/security/advisories/GHSA-c5mf-xmp2-59rc (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-114617 (opens in a new tab)
- github.com/authlib/authlib/pull/949 (opens in a new tab)
- github.com/authlib/authlib/commit/6563f6f7a8c2f71d2f85ee7511d72a4fbae3acc0 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.9.0 (opens in a new tab)