CVE-2026-59884: Aws shell · pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs
Affects aws-shellSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.2.2_15 soon.
Data as of 1 Nov 2026, 02:07 UTC
- Patch
- Available – fixed in 0.2.2_15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade aws-shell to 0.2.2_15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewaws-shellpkg:brew/aws-shellOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in pyasn1 version 0.2.2_15 that limits long-form tag IDs to 20 octets and improves error handling. Users should upgrade to this fixed version. As a workaround, applications can bound the size of untrusted input passed to decode() to prevent excessive resource consumption. No other mitigations are specified.
Description
A denial of service vulnerability exists in the pyasn1 BER/CER/DER decoder used by aws-shell, caused by unbounded long-form tag IDs. The decoder accumulates continuation octets without an upper limit, allowing crafted inputs to cause excessive CPU consumption and potential unhandled exceptions on Python 3.11+. This affects decoding of untrusted BER/CER/DER inputs. The issue is fixed in version 0.2.2_15 by limiting tag ID size and improving error handling.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-m4p7-r5rc-7g4j (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59884 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/628e36ecbb5277a3f01572ce418ef54271b165a5 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/pyasn1/PYSEC-2026-3455.yaml (opens in a new tab)