CVE-2026-59886: pyasn1 · Uncontrolled resource consumption when converting decoded REAL values
Affects aws-shellSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.2.2_15 soon.
Data as of 1 Nov 2026, 02:07 UTC
- Patch
- Available – fixed in 0.2.2_15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade aws-shell to 0.2.2_15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewaws-shellpkg:brew/aws-shellOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in pyasn1 version 0.2.2_15. Users should upgrade to this version or later. As a workaround, avoid converting, printing, or comparing decoded Real objects from untrusted sources and instead inspect the raw (mantissa, base, exponent) tuple to prevent triggering the vulnerability.
Description
CVE-2026-59886 is a denial-of-service vulnerability in the pyasn1 library affecting the univ.Real type. When decoding BER/CER/DER-encoded REAL values with very large exponents, converting these values to Python floats triggers excessive CPU and memory consumption, potentially hanging the process. This occurs during float conversion operations such as prettyPrint(), str(), comparisons, arithmetic, or explicit float() calls. The issue affects pyasn1 versions >=0.1.0 and <0.2.2_15 and is fixed in version 0.2.2_15.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-hm4w-wwcw-mr6r (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59886 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/e60c691cb91addb8fcefa2f537e85ede6fb1e886 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)