Skip to main content
VulnerabilityPublished Updated

CVE-2025-43804: Com.liferay:com.liferay.portal.search: Liferay search widget vulnerable to Cross-site Scripting

Affects com.liferay:com.liferay.portal.searchSource GCVE Database

0
Compare
Authoritative record:CVE-2025-43804· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade to 8.0.93 when convenient.

Data as of 4 Nov 2026, 18:51 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.0.93
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade com.liferay:com.liferay.portal.search to 8.0.93.

Affected software

ProductAffectedFixed in
Mavencom.liferay:com.liferay.portal.searchAffected
  • <8.0.93
Fixed in
  • 8.0.93

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in Liferay Portal version 8.0.93. Users should upgrade to version 8.0.93 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.

Description

A Cross-site Scripting (XSS) vulnerability exists in the Search widget of Liferay Portal versions 7.4.3.93 through 7.4.3.111 and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4. This flaw allows remote attackers to inject arbitrary web scripts or HTML via a specific userId parameter. The vulnerability is fixed in version 8.0.93.

References

Community reviews

Loading reviews…