Skip to main content
CVE-2026-77879VulnerabilityPublished

Control Web Panel (CWP) before webpanel_version 1.16 contains a SQL injection vulnerability in the loopback API

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-77879· High 8.5

Not known to be exploited · CVSS 8.5 High : upgrade to 1.16 soon.

Data as of 2 Nov 2026, 19:29 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.7
Patch
Available – fixed in 1.16
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Control Web Panel to 1.16.

Affected software

ProductAffectedFixed in
Control Web PanelControl Web PanelAffected
  • <1.16
Fixed in
  • 1.16

AI-suggested

A fix is available in Control Web Panel version 1.16. Users should upgrade to version 1.16 or later to remediate this vulnerability. No other mitigation guidance is provided.

Description

Control Web Panel (CWP) versions before 1.16 have a SQL injection vulnerability in the loopback API authentication gate access_token(). This flaw allows attackers to inject SQL via the authorization_code and client_id parameters, enabling them to read arbitrary database contents and bypass authentication checks.

References

Community reviews

Loading reviews…