Control Web Panel (CWP) before webpanel_version 1.30 contains a blind SQL injection vulnerability in an
Source GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.30 when convenient.
Data as of 2 Nov 2026, 19:30 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.2 |
- Patch
- Available – fixed in 1.30
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Control Web Panel to 1.30.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Control Web PanelControl Web Panel | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the vulnerable API routes and monitor for suspicious activity targeting these endpoints.
Description
Control Web Panel (CWP) versions before 1.30 contain a blind SQL injection vulnerability in an unauthenticated loopback API route. The vulnerability arises because the 'user' parameter is directly interpolated into a SQL query against the oauth_clients table, allowing attackers to perform time-based blind SQL injection and extract arbitrary database contents without authentication.