CVE-2026-119301: aws-sdk-pandas · Improper Neutralization of Quoting Syntax
Affects aws-sdk-pandasSource CVE Database V5
Not known to be exploited · CVSS 7.9 High : upgrade to 3.17.1 soon.
Data as of 2 Nov 2026, 17:43 UTC
Thin evidence
One scorer or none| CNA (AMZN) | CVSS 3.1 | 7.9 |
|---|---|---|
| CNA (AMZN) | CVSS 4.0 | 5.0 |
- Patch
- Available – fixed in 3.17.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade aws-sdk-pandas to 3.17.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AWSaws-sdk-pandas | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to AWS SDK for pandas version 3.17.1 or later to remediate this vulnerability. Since a patch is available and officially released by AWS, applying this update is the recommended mitigation.
Description
Improper neutralization of quoting syntax in SQL identifier construction in the Apache Iceberg write component in AWS SDK for pandas (also published as awswrangler) 3.5.2 through 3.17.0 might allow an authenticated remote user with permission to modify AWS Glue Data Catalog metadata to read any table that a separate, more privileged principal can access and write to the table that principal is updating via a crafted column name. To remediate this issue, users should upgrade to version 3.17.1 or later.