CVE-2026-119301: awswrangler · Improper neutralization of quoting syntax in Apache Iceberg SQL identifier generation in AWS SDK for pandas
Affects awswranglerSource AWS Security Bulletins
Not known to be exploited · CVSS 7.9 High : upgrade to 3.17.1 soon.
Data as of 2 Nov 2026, 18:58 UTC
Thin evidence
One scorer or none| CNA (AMZN) | CVSS 3.1 | 7.9 |
|---|---|---|
| CNA (AMZN) | CVSS 4.0 | 5.0 |
- Patch
- Available – fixed in 3.17.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade awswrangler to 3.17.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIawswranglerpkg:pypi/awswranglerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in awswrangler version 3.17.1 and later. Users should upgrade to version 3.17.1 or newer to remediate this vulnerability. No other mitigation guidance is provided in the bulletin.
Description
CVE-2026-119301 is a vulnerability in the Apache Iceberg write component used by the AWS SDK for pandas (awswrangler). It involves improper neutralization of quoting syntax in SQL identifier generation, which could allow an authenticated user with permission to modify AWS Glue Data Catalog metadata to read tables accessible by a more privileged principal and write to those tables via crafted column names. The affected awswrangler versions are from 3.5.2 up to, but not including, 3.17.1.